Symptoms
Customer cannot upgrade Plesk license provided within OSA subscription.
Subscriptions > click subscription > [Licenses] tab > click license > [Upgrade License]
Below is the error:
Empty "IN" operator value list passed.
Checking the license status:
BA > Services > Licenses > Searched for license
License it not synced.
Syncing the license results in
Discrepancy is found. License on KA contains: REINSTATE_SUS unlike a PBA.
Cause
The issue is software related with ID PBA-62504
Resolution
The issue will be fixed in one of the future product updates.
Apply the following workaround:
Check in PBA DB by the license feature:
select * from "KA_Feature" where "FeatureID"='REINSTATE_SUS'; FeatureID | SortNumber | UserArc | DateArc | resourceID ---------------+------------+---------+------------+------------ REINSTATE_SUS | 3384 | 1 | 1386672995 | 100628
Look for this resource in the subscription resources and service plan. Most probably this resource is not present in both.
- Add resource rate for resource 100628 using Configure Licenses/Features button and synchronize the subscription(s), synchronize the license then upgrade the license.