Symptoms
Not all the staff members are able to change the subscription expiration date, the button is absent on the subscription general page Home> Operations> Subscriptions> Subscription #ID
Cause
The staff members role does not have the privilege MANAGE_CUSTOMERS_SUB_TERMS
Resolution
Attach the privilege to the role or add a new role which contains the privilege. If that is reseller's staff member, the privilege must be included in the list of the delegated privileges to the resellers service template..