Symptoms
Attempt to cancel some old order in the status "Provisiong Failed" fails:
Communication Failure: Error in method invocation
or
ODBC code #08S01: No response from the backend
In the logs it can be seen that the failure happens in PEMGATE::ServiceDestroy
on attempt to get information about the account from OA:
[15-07-07 08:46:54.581 XMLRPC RQ479133 TH31844 TRC] REQUEST: pem.getAccountSubscriptions : { 'account_id' => 1000002, }
[15-07-07 08:46:54.594 XMLRPC RQ479133 TH31844 TRC] RESULT: <?xml version="1.0" encoding="UTF-8"?>
<methodResponse><params><param><value><struct><member><name>error_code</name><value><i4>1006</i4></value></member><member><name>error_message</name><value><string>There is no such account #1000002.</string></value><member><member><name>extype_id</name><value><i4>10</i4></value></member><member><name>module_id</name><value><string>AccountManagement</string></value></member><member><name>properties<name><value><struct><member><name>account_id</name><value><string>1000002</string></value></member></struct></value></member><member><name>status</name><value><i4>-1</i4></value></member></struct></value></param></params></methodResponse>
Cause
Account has not been created in OA. The issue that such orders cannot be cancelled is considered as a product bug with id #FND-3331 ("Not possible to cancel an order when there is no account in POA").
Resolution
The workaround is:
- Eliminate the reason of a failed task for the account creation (usually it is either incorrect account information, e.g. missing email or address for accounts created with API or absence of the resource
Client accounts
for the reseller). Resubmit this event. If the event cannot be found in the list of failed tasks, trigger a new one:
- Home> System> Settings> Event Types> Account Created
- Trigger Event
- enter parameters as
AccountID=xxxxxxx
(xxxxxxx - required account id) - click Send
- Account will be created in OA and you shall be able to cancel an order.