Symptoms

The task for Office 365 subscription provisioning fails with the following error in task manager:

APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] Provisioning: resource f8a32766-3194-401f-89d5-9d22aee33011 of type 'tenants' (http://www.parallels.com/Office365/Tenant/1.1) for APS application 'Microsoft Office 365-6.1-107': Request error: 400 Bad Request.

Body: {
"code": 500,
"message": "Request error: 400 Bad Request",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError",
"http_request": "POST /O365App/aps/tenants to 'o365.domain.tld'"
}

In the sitelog log file on application endpoint host the following error is found during the task execution:

2015-07-17 01:18:37,999 [   5] DEBUG mmandRequest: Received error response 400 Bad Request:
{"parameters":{"property_name":"state, postal_code, city"},"code":"4031","error_code":"InvalidProperty","message":"State Code ON, ZIP Code i8u7y6 and City/Town Name city001 combination passed not found.","object_type":"Error"}

Or:

2015-08-16 20:05:58,177 [   8] DEBUG mmandRequest: Received error response 400 Bad Request:
{"parameters":{"property_name":"postal_code"},"code":"4039","error_code":"InvalidProperty","message":"ZipCode is invalid or null 1234567.","object_type":"Error"}

Cause

There is a validation of ZIP codes and cities pairs on Microsoft CREST API side, so it is impossible to provision subscription with wrong ZIP code/city pair.

Resolution

Change ZIP code/City combination in customer account to valid one. It can be done by the following step in OA provider CP:

  1. Under the Operations > Customers select the required customer account;
  2. Change address properties on the General tab.

Internal content