Symptoms
When the steps below are followed:
- Home -> Operations -> Subscriptions -> subscriptionID
- Click on Service Plan ID on the General page
- Click on "Subscription Periods" tab or "Resource Rates" tab.
an error occurs:
Table Service Plan doesn't contain row with id Int32(NULL).
Cause
This issue is caused by product bug with id #PBA-62342.
Resolution
As a workaround perform the following steps:
Create file
/usr/local/bm/customization/Plan_MyPlanList.xml
with the following content
<window id="Plan_MyPlanList"> <actions> <action id="StandardInput"> <call type="server" callee=BM::GetMyServicePlans(sortno) return=PlanID, name/> <call type="server" callee=BM::GetCurrentAccountID() return=AccountID /> </action> </actions> </window>
Restart WWW container:
/etc/init.d/www restart
You will need to remove the customization file after update with bug fix is installed.