Symptoms
Permissions cannot be retrieved when going to POA Customer Control Panel > File manager and opening Get info
for any file:
Size : 9 KB
Path : HTTP/tests
Modified : Jul 25, 2013 07:17 PM
Locked : no
Application Pool User : failed
Webspace Group : failed
Anonymous Users : failed
Browser console shows
{"error":"Failed to get permissions for <USERNAME>}
Where <USERNAME>
contains the webspace ID
Cause
445 and 139 ports between Windows File Manager and Windows shared hosting nodes are filtered.
- File manager identity permission is not added to the permissions list of the webspace in question.
Resolution
The ports 445 and 139 are used by Windows File Manager during some operations with files permissions. These ports should be opened between Windows File Manager node and Windows shared hosting node. Otherwise, the user won't be able to edit permissions via Windows File Manager. This information is added to the Firewall Configuration Guide
In case the network is not limited, do the following:
- Access the File Manager host,
- Access IIS manager,
- Locate the Application pool identity of the application pool used by the webfilemanager site,
- Access the IIS server hosting the webspace,
- Verify that the WFM idenity has access to share (Right-click customer data > Properties > Sharing > Permissions...)
- Verify that the WFM identity has permissions to access individual files inside webspaces (these permissions are inherited from CustomerData)