Symptoms

Estimated price for PACI server is shown as zero in the Customers control panel. It is not changed when one changes resources allocation.

The following error is written to poa.debug.log on attempt to purchase a new server:

Dec  8 19:15:04 osscore : DBG [openapi:192.168.30.8:4430 1:18701:aedfbbb0 lib]: [void<unnamed>::getAverageSummaryUsage] {module_id="ResourceManagement"; code="15"} Resource type #ID does not exist.
Dec  8 19:15:04 osscore : DBG [openapi:192.168.30.8:4430 1:18701:aedfbbb0 chief]: [void<unnamed>::getAverageSummaryUsage] <=== EXIT (by exception) [0.005180]
...
[BM::Bridge_impl::performCall] {module_id="BMBridge"; code="10"} PBA reported error while trying to retrieve subscription prices from PBA.  Error: -1, 'Parallels Operations Automation error #error_code #2006, extype_id #15, module_id #ResourceManagement, Resource type #ID does not exist..'.

Cause

Inconsistency of subscription resources between POA and PBA. Resource was deleted from the service template, but was left in the service plan and/or in the subscription on PBA side.

Resolution

The way to resolve depends on the desired result. If you do not need this resource in this and other subscriptions based on this service plan, then:

  1. Delete the resource with reported ID from the service plan, if it exists there.
  2. Synchronize the subscriptions with the service plan, choose options "Remove obsolete resource(s)" and "Install into Provisioning System" - "Not Install".
  3. * If the step 2 fails, please contact Parallels technical support for assistance.

If the resource is required, then:

  1. Deactivate the service template on POA side.
  2. Add the resource to the service template.
  3. Activate the service template.
  4. Make sure correct resource rate limits are set in the PBA service plan.
  5. Synchronize the subscriptions with the service plan to make sure correct limits are set for the resource

Internal content

Link on internal Article