Symptoms

During reseller initialization on some step of Reseller Setup Wizard error appears:

Call to FILE container failed 

Cause

This issue caused by missing image.

Resolution

Please check one of the following images:

  1. Plan Image:

    SELECT "AccountID","PlanID","ImageID","DocID" from "Plan" left join "BlobDocument" on ("Plan"."ImageID"="BlobDocument"."DocID") WHERE "ImageID" is not null ORDER BY "ImageID";
    

    if DocID is empty for some plan please go Products > Service Plans > [plan_with_id_from_select] > Publication Seetings in PBA-E 5.5 and later or Product Director > Plan Manager > Service Plans > [plan_with_id_from_select] in PBA-E 5.4 and earlier and click Remove Icon button;

  2. Store's logo:

    SELECT "StoreID", "Value", "DocID" from "StoreGeneralParamVendor" left join "BlobDocument" on ("StoreGeneralParamVendor"."Value"="BlobDocument"."DocID") where "ParamID" = 'LOGO';
    

    The issue is fixed in PBA-E 5.5. Please upgrade to the latest version of PBA-E. In PBA-E 5.4 please go Home > Product Director > Online Store Manager > General Parameters > DESIGN > LOGO and click Set Default button;

  3. Store Categories:

    SELECT "CategoryID", "StoreCategory"."DocID" as "ImageID", "BlobDocument"."DocID" as "DocID" from "StoreCategory" left join "BlobDocument" on ("StoreCategory"."DocID"="BlobDocument"."DocID") where "StoreCategory"."DocID" is not null;
    

    if DocID is empty for some category please go Products > Service Plans > Sales Categories > [category_with_id_from_select] in PBA-E 5.5 and later or Product Director > Plan Manager > Sales Categories > [category_with_id_from_select] in PBA-E 5.4 and earlier and click Remove Icon button.

  4. Store Path

    select "StoreID", "StorePathID", "StorePath"."DocID" as "ImageID", "BlobDocument"."DocID" as "DocID" from "StorePath" left join "BlobDocument" on ("StorePath"."DocID" ="BlobDocument"."DocID") where "StorePath"."DocID" is not null and "StorePath"."DocID" not in (select "DocID" from "BlobDocument");
    

    If the query returns some results it is required to upload the logo for the problem scenario: Home > Products > Online Store > scenario, click Change Icon

Then please synchronize reseller and complete wizard.

Internal content