Symptoms

Renewal order has been provisioned successfully while the customer does not have default payment methods specified. The payment was created for the Renewal Order automatically.

It was expected that Order would stuck in waiting for payment until payment is created manually. How to configure to prohibit payment creation.

Cause

There is a global setting in:

Home > Operations > Payment Methods

One of the payment methods is marked as "Default Payment Method for Customers".

Resolution

In order to prohibit automatic order processing, provider should verify that:

1) Account does not have any payment method marked as default (Autopayments On) in:

Home > Operations > Customers > [Customer ID] > Payment methods

2) The "Auto Apply Credits" setting is set to Off in the customer class, the account belongs to:

Home > Settings > Customer Classes > [Customer Class ID]

3) Global setting "Default Payment Method for Customers" is set to Off for any of the payment methods in:

Home > Operations > Payment Methods

Internal content

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