Symptoms

We do not provide access to PBA for the customers (an option "Hide billing item in CCP" is enabled). Since upgrade to PA 5.5 adding new staff member is not possible, the button "Add new user" is grayed out in CCP.

Cause

The issue is considered as a bug with id #POA-87825.

Workaround

  1. Disable "Hide billing item in CCP" option, so billing elements will appear in CCP.
  2. Modify privileges for Customer Full Access role on PBA side (PBA > System > Settings > Security > Roles > Customer Full Access > Privileges) - detach all privileges except MANAGE_OWN_ACCTINFO_C.

This way you will have ability to change account information, including ability to add new staff memebers, but all billing functionality will be hidden (payments, renewal options and so on).

If there are still some undesired PBA elements left in CCP after the above change, they can be removed using the PBA UI customization:

PBA UI Customization guide

Internal content