Symptoms

While paying orders via redirect payment (Payment Plugin Assist, Payment system QIWI),

The following error can appear in Control Panel: ExceptionResult: Can't get transaction details: invalid response received. Please check the payment status using ASSIST Control Panel

The payment itself completed successfully, however on PBA-E side it is shown as not completed.

Cause

The button "Return to Control Panel" on Assist window is pressed too early - the payment on Assist side is still in process. Due to the uncompleted status of payment, PBA-E Assist plugin returns "Not OK" to PBA-E.

The issue caused by the current Assist protocol implementation.

Resolution

It is necessary to wait until QIWI payment tn is fully completed and then press "Return to Control Panel."

Internal content