Symptoms

Provider is trying to create a new Mass Printing task in the PBA-E Home> Finance> Mass Printing> New Print Queue> select_needed_documents> Save

However the following error appears:

The proxy server received an invalid response from an upstream server.

The proxy server could not handle the request GET /bss-www/sudo1-729cb92cbb23444ed63c5141381031c3/act/MESSAGE/PrintQueueDet_ARDocToNewPrintQueueList/StandardInput.

Reason: Error reading from remote server

Cause

Preparing a list of documents for mass printing (particularly database select to get required data) may take considerable time in some cases. The error displayed in the Control Panel caused by apache timeout during queue generation.

Resolution

Feature request PBA-59058 exists to improve Mass printing queue generation time.

Apache timeout on POA Branding host can be increased (for the case when PBA-E is integrated with POA):

  1. If brand hosted on standard shared hosting server, change timeout in following file:

    Edit /usr/local/pem/etc/apache/httpd.conf_pem Increase

    TIMEOUT 300
    

    to desired value. For example if operation takes 10 minutes, you need to set:

    TIMEOUT 600
    

    Reload the config:

    /etc/init.d/pemhttpd reload
    

    NOTE! Timeout value in main config can be overriden in another configuration file listed in the INCLUDE directive of the main one. Check Website Hosting: Apache service article for details.

  2. For brand hosted on server with NG hosting, change timeout in following file:

    Edit /etc/httpd/conf.d/ng_custom.conf

    Timeout 120
    

    change option to desired value. For example if operation takes 5 minutes, you need to set:

    Timeout 300
    

    Reload apache to apply configuration:

    /etc/init.d/httpd reload
    

If increasing timeout does not help it might be necessary to re-index PBA-E database tables "Account" and "ARDoc" that are used by this operation.

To re-index table please use the following command:

pba=> REINDEX INDEX "TableName";

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