Symptoms

Upgrade order for plan change fails with error like:

Failed  Change Service Plan failed: Parallels Operations Automation error #extype_id #37, module_id #AAA, Cannot unprovide RTI (rtiId 'XXX') (rcName 'YYY').. . 

or

Change Service Plan failed: Parallels Operations Automation error #error_code #2005, extype_id #100, module_id #ResourceManagement, Resource 'XXX' overusage attempt (subscription #YYY, usage ZZZ, limit VVV).. .          

But resource is present in both service plans with identical Included value and there is no additional amount of the resource in subscription.

Cause

Parallels Operation Automation API version 5 is configured to be used in PBA-E for communication with POA and limit for the resource is lower in service template of the plan to which you are trying to upgrade subscription then in service plan from which you are trying to upgrade subscription.

Resolution

Change POA API version to 6 in Home>External Systems Director>Parallels Operations Automation>Settings in PBA-E 5.4 or Home>System>Settings>POA Integration>Settings in PBA-E 5.5 option Select Parallels Operations Automation API.

When POA API version 5 is used then during change plan API method pem.upgradeSubscription is called to PBA-E without checking limits of service plans. Thus limit of service template are used. If it is lower then in service plan from which you are trying to upgrade the POA will try to unprovision resource.

When POA API version 6 is used then PBA-E first collects limits from Service Plan and calls pem.upgradeSubscription with this limits.

Alternatively, if both service plans are based on the same service template, then it is possible to change limit of the resource in service template via POA. Please note that all service plans on this service template should have defined resource rate for this resource in order to avoid problems when resource is provisioned where you do not want it.

Internal content