Symptoms
Error "There should only be a single RMS Shared Identity user" appears when Exchange upgrade process is going.
Cause
There exists a duplicate account FederatedEmail.<ID>
in Exchange.
Resolution
Remove the double FederatedEmail.<ID>
e-mail account by using the adsiedit tool as described on Microsoft Answers:
To do this, follow these steps:
- Click Start
- Click Run
- Type adsiedit.msc
- Then click OK.
- Locate the Default Naming Context node
- Then locate to the CN=Users container.
- Locate and then right-click the CN=FederatedEmail.
<ID>
container. - Then, click Delete.
- Re-run upgrade
In case this you cannot choose account to delete or if you remove one and that did not help - remove all those two federatedemail account and then create a new one.
- Remove both accounts
- Rerun the Exchange Server 2010 Mailbox role setup application.
Create a new federated e-mail account by using the following command:
PS> New-Mailbox -Arbitration -Name FederatedEmail.<ID> -UserPrincipalName FederatedEmail.<ID>@<Default_Accepted_Domain>