Symptoms

  • Orders for POA subscriptions fail with an error "Service Creation Timeout Exceeded".
  • There are no unprocessed tasks for the subscription on POA side, checking kb #116854 shows no failed tasks on PBA side.
  • The subscription is available in the provider's control panel, but does not appear in the list of the subscriptions in the customer's control panel.
  • Checking the list of processed tasks in POA shows that there is no task "Post Event to PBA" (or "processing event 'Subscription provisioned'") for this subscription.
  • PEMGATE.log shows an error Parallels Automation Operation is not available for the requests to POA.

Cause

One of the tasks in POA timed out, in poa.debug.log you will see a record like:

Request has been timed out, details: system exception, ID 'IDL:omg.org/CORBA/TIMEOUT:1.0' TAO exception, minor code = 3e (timeout during recv; low 7 bits of errno:  62 Timer expired), completed = MAYBE

This caused new tasks being queued and not event posted. The issue was reported in the bug #POA-82916 ("Long running and timed out task in some SC can cause other tasks in this SC to timeout as well").

Resolution

The issue is fixed in POA 5.5.6.

To start the tasks posting and processing, POA restart is required.

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