Symptoms

Service plan was created on service template with One-time Fee Item set to Yes. How customer can purchase several items at once?

Cause

It is not possible to add any resources to One-time Fee Item service template or service plan based on such service template. There is no direct way to purchase several One-time Fee Item service plans at once.

Resolution

There are 2 ways to workaround the problem.

  1. Create several service plans with different prices for different number of one-time fee items. It may be necessary to create several service templates in case when resources are provisioned via some script specified in Home>Product Director>Plan Manager>Service Templates>[service_template_on_dummgate]>Service Creation in PBA-E 5.4 or Home>Products>Service Plans>Service Temaplates>[service_template_on_dummygate]>Service Creation in PBA-E 5.5.

    • Create usual service templates(without selecting option One-time Fee Item).

    • Create resource for necessary item create.
    • Create service plan based on service template from step a. Set only setup fee for the plan, leave all other fees 0.
    • Add resource from step b, to service plan with included = 1, max limit = [desired_max_amount], with only setup fee set for the resource.

Internal content