Symptoms
An account and its subscriptions, or any specific customer's subscription has different statuses in POA and PBA - disabled in POA, but active/running in PBA. In POA there is no button to activate/enable a subscription or an account, how can its status be changed?
Cause
The cause is to be investigated additionally - an account was taken from credit/administrative hold, but the subscriptions were not enabled in POA due to some reason, it is possible that bug #PBA-53697 is a reason of the issue. The logs /var/log/poa.debug.log on POA side and /usr/local/bm/log/PEMGATE.log on PBA side are to be checked for the root cause investigation.
Resolution
If you require an account/the subscriptions to be active in both systems you can choose one of the methods below:
I. Enable them with POA API methods:
- for the specific subscription - pem.enableSubscription
- for the account - pem.enableAccount, this method enables all the disabled customer's subscriptions.
II. Enable them from PBA by triggering an event
for the specific subscription:
PBA 5.4: PBA Provider Panel > Configuration Director > Event Manager Settings > Event Types
PBA 5.5 and PBA 6.0: PBA Provider Panel > System > Settings > Events > Event Types
Locate event type
Subscription Taken From Hold
, click on it.Click the button
Trigger Event
, in the fieldparameters
please enter:subscriptionID=YYY;
where YYY is an ID of the subscription that should activated on POA side.
for the account:
PBA 5.4: PBA Provider Panel > Configuration Director > Event Manager Settings > Event Types
PBA 5.5 and PBA 6.0: PBA Provider Panel > System > Settings > Events > Event Types
- Locate an event type
Account Taken From Hold
, click on it. Click button
Trigger Event
and in filed parameters please enter the following:AccountID=XXX;
where XXX is an ID of the account you want to activate on POA side.
Please note that triggering an event from PBA will not work with the domain subscriptions in PBA 5.5 till PBA 5.5.4 due to bug PBA-53697 (refer to the kb #120538).