Symptoms
PBA is integrated with Kayako according to the documented procedure . Connection to the external helpdesk works but Kayako is not opened in Account > Support Tickets in the customer control panel (CCP), neither in Chrome, nor in IE, am empty window is displayed. You may see an error in the browser console:
Refused to display 'URL' in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.
In some versions of Mozilla Firefox it can be opened but is displayed in the same window, not in frame, the customer leaves CCP when accessing Kayako.
Cause
Since 4.61 version Kayako does not support loading in a frame.
Resolution
Prevent redirects to Kayako website in the customer control panel:
- Login to admin Kayako control panel.
Modify the
header
template by removing<meta http-equiv="X-Frame-Options" content="SAMEORIGIN" />
See the details how to modify the template, if required - Kayako documentation (chapter
Editing a template
)Modify the
footer
template by removing<script type="text/javascript" >try {if (top.location.hostname != self.location.hostname) { throw 1; }} catch (e) { top.location.href = self.location.href; }</script>
Rebuild Kayako cache: access in browser
https://<hostname>/<directory with kayako>/staff/index.php?/Core/Default/RebuildCache
hostname and directory are to be substituted with real values.
These actions shall let Kayako be loaded in the same frame.