Symptoms
Kayako is integrated with BA. Customers can access it CCP Account > Support Tickets. However they are not automatically logged in through Help & Support > Trouble Ticketing link.
Cause
Help & Support > Trouble Ticketing link leads to the url specified in POA System > Settings > System Properties > General:
Trouble Ticketing System URL http://www.support.com
Kayako url can be put in the setting, however auto-login is not implemented on this screen
Resolution
Feature request #POA-58525 ("Integration with Kayako") exists to implement auto login.