Symptoms

No scheduled backups are getting created, despite the backup schedule is configured.

There are no errors recorded into Cloud Infrastructure Log.

Cause

2 possible causes:

  • No free space on Virtuozzo backups node(s)
  • Stuck DB entries of previous backup operations that were not ended/removed

Resolution

OACI backups are scheduled according to the settings in /usr/local/share/PACI-im/IM-config.xml:

<!-- backup job details -->
<backups batchSize="10" intervalInMin="1" maxDurationInMin="200"/>

By default, OACI runs backups in 10 VE batches. Available free space on the backup nodes is checked using the sum of 10 VEs that should be backed up.

Calculate maximum size of the 10 biggest VEs:

im=# with topdisks as (select size from ve_storage where ve_ref in (select id from ve where template_id in (select id from templates where ((os_type in (select type from os_types where family='linux') and technology='CT')) or technology='VM')) order by size desc limit 10) select sum(size) from topdisks;
sum
-----
1625

In this example, ~1.65 T of free space is required for performing 10 biggest VEs backup batch. Verify that OACI backup nodes have enough space to accommodate the backups.

As a workaround, change batchSize to "5". In this case the backup task will run smaller batches that will require less space. Note that any changes in IM-config.xml require PACI-IM service restart.

service PACI-im fast-restart

In case it did not help, contact your Technical Account Manager or Pooled Technical Associates team (pta@cloudblue.com) in order to check issue and apply internal workaround.

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