Symptoms

UpdateObjAttrList_API is executed successfully with the response "Operation done", but the attribute values are not updated. Attribute that needs to be updated has only COMP tag, can be checked in Home > System > Settings > Attributes.

Cause

UpdateObjAttrList_API incorrectly treats account attribute tags and tries to update personal attributes only. The issue is confirmed as a bug, #PBA-53296, fixed in PBA 5.5.4.

Resolution

Until update is available, you can either

1) add PERS tag to the attribute, if acceptable. Execute the call again

or

2) update the attribute manually:

Home > Operations> Customers > needed Account > Additional Information tab

Internal content

Link on internal Article