Symptoms

A task to update statuses of BlackBerry accounts fails with:

Last execution output   Destination host 'BES-01' (#25), IP '' : Provisioning request failed. Unknown error 0x80131500 [<response><errorContext description="Unable to execute any BlackBerry User Admin Tools:
BES5: Target server not responding\n BES4: BESUserAdmin tools not found" code="0x80131500" executeSeqNo="1"><errorSource namespace="BESProvider" procedure="getUser"/></errorContext></response>]

Cause

Key word is "BES5: Target server not responding".

During task processing the following procedure is executed on MPS:

Tag Procedure Enter
Log Level 4
Process ID 0x32b8
Thread ID 0x3f50
Description CMapsStepInstSCO::ExecuteNextStep entering procedure
machine MPS-01
namespace BESProvider
procedure getUser
execute xml -<executeXml>
-<context>
 <securityContext trustee="pem_admin" impersonate="1" />
 <transactionContext transactionId="{0EC58C0A-6322-4CFD-84AB-8D38B2762397}" />
 <executeContext procedure="getUser" procedureExecId="1" providerSource="Provisioning.Providers.SWsoftProvider" namespace="BESProvider" type="twophase" />
 </context>
-<executeData>
 <adminServiceHost>BAS-01</adminServiceHost>
 <adminServicePassword>********</adminServicePassword>
 <adminUserDomain>provider.local</adminUserDomain>
 <adminUserLogin>pem_admin</adminUserLogin>
 <adminUserPassword>********</adminUserPassword>
 <okIfNotExist>true</okIfNotExist>
 <userEmail>email</userEmail>
 </executeData>
 </executeXml> 

Trying to log into BAS server manually you may the following error:

There are currently no logon servers available to service the logon request.

According to Microsoft discussions local system administrators should login to server manually and check services like winlogon. Probably, a reboot is needed.

Resolution

Contact system administration team to fix this error. Reboot of server may be required in order to re-initialize services.

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