Symptoms

The following is true:

  • A domain is not In Sync in the Customer Control Panel (CCP).
  • The domain is Active in the Plesk Control Panel (CP).
  • Domain tasks have completed successfully in the Plesk CP.

On resubmitting to the Plesk CP, the following error occurs:

Failed to Add 
Parallels Plesk Panel (id=<ID>) is not ready to perform operation

Cause

Plesk was not initialized correctly due to a bug in Operations Automation (OA). This is either POA-71208 (in OA 5.4) or POA-81145 (in OA 5.5, but less than 5.5.3) or POA-82214 (in OA 5.5, but less than 5.5.4).

Resolution

Provided that everything is correct inside Plesk, the following solution can be used:

  1. Check that the 'operations' field for this Plesk instance has a value of 4 (the following queries should be run in the OA database on the OA Management Node):

    plesk=> select operations from psa where id=<ID>;
    operations
    ----------
    4
    (1 row)
    ----------
    

(Where <ID> is the <ID> from the error message.)

  1. Reinitialize Plesk: Home > Plesk Panel Reinitialize button.

    If the Reinitialize button is not available, use the following query in the POA database:

    plesk=> update psa set operations = 15 where id=<ID>;
    
  2. Resubmit the domain to Plesk, which should restore its sync state.

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