Symptoms

Task to update Excahnge mailbox fails in POA with the following error message:

There are multiple primary SMTP addresses. Please ensure there is only one primary address for each address type.

More detailed diagnostics is provided in the example below:

Task name       Set access options for mailbox '<MAILBOX_NAME>' (id=379468)
Last execution output   Exception during execution of MPF request: 'Unknown error 0x80131600 [<response><errorContext description="There are multiple primary SMTP addresses. Please ensure there is only one primary address for each address type.
Cmdlet='Set-Mailbox'
DomainController='AD01.hosting.local'
Identity='LDAP://CN=,OU=S0000001827,OU=R0000000003,OU=Hosting,DC=hosting,DC=local'" code="0x80131600" executeSeqNo="2"><errorSource namespace="Exchange 2007 Provider" procedure="ModifyMailbox"/><errorSource namespace="SW Managed Exchange" procedure="ModifyMailbox"/></errorContext></response>]'.
'Externel email address' 

Cause

More than one primary SMTP address is specified for the mailbox in question in the Active Directory.

Resolution

Use the 'adsiedit.msc' tool on the Active Directory domain controller to check the properties of the system user owning the mailbox mentioned in the failed task, namely - check the proxyAddress attribute of the user in AD.

If the proxyAddress attribute contains more than one value starting with 'SMTP:' (in upper case, it means the address is primary) then this is the problem.

Find the primary email address of the Exchange mailbox in the POA Customer Control Panel of the corresponding customer account and correct values in the proxyAddress attribute of the user in the Active Directory - leave anly one entry starting with 'SMTP' (for the primary email address found in the POA Customer CP) and change all other entries to 'smtp' (lower case).

Internal content