Symptoms

After re-attaching DNS node, PPA panel shows the error:

Error message or request description : Destination host 'vmsdc1intpkl02' (#5), IP '1.2.3.4' : Internal error: /usr/sbin/rndc /usr/sbin/rndc reload 4.3.2.IN-ADDR.ARPA. failed with code 1 saying: STDOUT: '' STDERR 'WARNING: key file (/etc/rndc.key) exists, but using default configuration file (/etc/rndc.conf)
rndc: 'reload' failed: not found

Cause

Re-attaching DNS node corrupts the DNS records in /var/named/run-root/var/pem_zones.

Resolution

To restore broken domain zone for domains it is necessary to remove DNS hosting from each domain temporarily and add it back.

Follow the steps below to restore broken/missing domains zones on DNS servers in CP:

  1. Log into CP

  2. Switch to the DNS Management > DNS Zones tab

  3. Choose the problem domain

  4. Switch to DNS tab

  5. Click the Change DNS Hosting to External button

  6. On the next step click the 'Finish' button - DNS hosting will be removed for the domain (domain will be removed from managed DNS servers)

  7. Click the 'Change DNS Hosting to Internal' button in domain properties

  8. On the next step select the desired subscription with DNS Hosting resource from drop-down list

  9. Click 'Next' and 'Finish'

  10. Wait until corresponding background tasks which update managed name servers are processed in Task Manager. For Bind-based DNS servers tasks are named like 'Update named ns1.provider.com(#1)', where ns1.provider.com is the hostname of DNS server and #1 is its ID in database.

Note: Keep in mind that it may take couple of minutes while PPA processes tasks.

As a result of the actions above DNS hosting will be removed for the domain and will be added back - domain zone will be recreated using data from database. All existing DNS records (including ones manually created) will stay in touch because PPA does not remove them from database when DNS hosting is being removed for the domain.

Internal content

Feature reques to automate the algorithm:

https://support.parallels.com/Ticket/TP/ShowTP.html?id=1774976&ReqDataID=10384

3rd-line ticket:

https://support.parallels.com/Ticket/Display.html?id=1774976