Symptoms

Provisioning or reconfiguration tasks of the BackupAgent APS application fail with the 'Internal Server Error' error message, e.g. like in the example below:

Failed to remove BA user customer@customer.com for subcription 1000101: Internal Server Error

Cause

There may be several reasons of the problem:

  1. Incorrect BackupAgent administrator credentials in the POA APS resource type, corresponding error message should be logged in the Windows Event Log on the BackupAgent server in this case.

  2. Date/time on the POA-managed Provisioning Gateway is wrong. BackupAgent denies requests with incorrect timestamp. There is no error message in Windows Event Log in this case.

Resolution

  1. Check the global settings of the BackupAgent Application resource type in the POA Provider Control Panel:

    • Go to Service Director > Application Manager > Applications
    • Click on the BackupAgent application
    • Switch to the Resource Types tab
    • Click on the resource type of the Application resource class
    • Switch to the Activation Parameters > Global settings tab
    • Make sure that the values of the following parameters are correct:

      • BA administrator login
      • BA administrator password
    • Try to log into the BackupAgent Management Console using the credentials stored in POA
  2. Check and correct if necessary date and time on the Provisioning Gateway, where POA executes the BackupAgent configuration scripts. Consider to configure NTP (Network Time Protocol) client on the host to synchronize time in the future.

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