Symptoms

PBA for Linux migration check fails with the following error message:

Can't get PBA version, PBA installed but version format is incorrect

More detailed diagnostics is provided in the example below:

# pba_migrate check
......
+4s [INFO ] [Migration] Check connection state for `pba.store`
+5s [INFO ] [Migration] `pba.store` is available. Exchange SSH keys.
+5s [INFO ] [Location] Keys already exchanged
+5s [ DIE ] [Location] Can't get PBA version, PBA installed but version format is incorrect(5.4.14.custom-067)
[Call stack]:
    'Log::blog' at line 132
    'Location::get_pba_version' at line 426
    'Migration::check_environment' at line 237
    'Migration::_init' at line 72
    'Migration::new' at line 33
    'main::do_check_config' at line 449
    'main::main' at line 552

Cause

Custom version of PBA package is installed; in the example above the custom version 5.4.14.custom-067 is installed is installed on the PBA Online Store, you may check it using the rpm utility:

# rpm -q bm-templatestore
bm-templatestore-5.4.14.custom-067

The PBA Migration utility cannot recognize the custom version of the Online Store as valid.

Resolution

Clarify with the Account Manager if custom fixes were included into the mainstream version of the product and install the regular version of the PBA.

For example, to solve the problem with PBA migration in this particular case:

  1. Make sure with the Account Manager that custom fixes were included into some already released PBA Online Store update.
  2. Create fresh backup of the PBA Online Store server.
  3. Download installer of the Online Store from the corresponding PBA update.
  4. Update the Online Store to the regular version.
  5. Run the PBA migration script again.

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