Symptoms
The user is prompted to enter the login/password when purchasing the new service in CCP when the redirect to on-line store is configured.
Cause
Incorrect redirect settings.
Resolution
For such authorization (from CCP to store) to work correctly the redirect settings must be configured:
Create redirect. You can find instructions in the documentation for PBA-E 5.4 or for PBA-E 5.5.
URL shall be
NAME_PATH=
if you want the user to be redirected to the first screen of the store.Synchronize the store:
PBA 5.4: Home > Product Director > Online Store Manager > Synchronization Settings Synchronize button
PBA 5.5 Home > Products > Online Store Synchronize Now button
Set the correct redirect settings
PBA 5.4: Home > Configuration Director > Miscellaneous Settings > Redirect Settings > New Subscription
PBA 5.5 Home > System > Settings > Customer CP > New Subscription
for example:
https://myonlinestore.com/index.php?redirect=my_redict_name&operationType=login&Token=@@User_Token@
set Target to
Main Frame
for store be opened in a frame of CCP.