Symptoms
On attempt to purchase a domain plan and select parent subscription for it PBA displays the 'No Parent Subscription' message like on the screenshot below:
Also, the same situation may happen when trying to assign a parent subscription to an existing domain subscription:
- A customer has a hosting subscription and a domain subscription in their PA account
- The customer (or Provider on a customer's behalf) is trying to assing the existing hosting subscription as parent one to the domain subscription
- PBA Control Panel says 'No Parent Subscription' despite of the fact that the customer has hosting subscription
Cause
Up-sale categories are configured incorrectly in PBA.
Up-sales list may be configured for each Service Plan individually. To make a Service Plan presented in the parent subscriptions list, it is necessary to include appropriate Sales Category in the up-sales list of the parent subscription Service Plan.
Normally, a hosting subscription is being configured as a parent one for a domain subscription. So, hosting Service Plan of a parent subscription should have up-sales configured and the Sales Category which includes domain Service Plan that a customer is trying to purchase or set as a parent subscription must be included in up-sales configured in the hosting Service Plan.
So, in the case above either the domain Service Plan is not included into a Sales Category configured as up-sale in the hosting Service Plan or the hosting Service Plan has improper Sales Category configured as up-sale (or even does not have any Sales Category configured as up-sale).
For more details of up-sales configuration refer to the PBA documentation - Forming Service Plan Up-sales List.
Resolution
Follow the steps below to resolve the issue:
- Log into the PBA Provider Control Panel
- Go to the Product Director > Plan Manager > Sales Categories
- Find the Sales Category which includes the domain Service Plan in question or create the new Sales Category and include the required domain Service Plan into it, remember name/ID of the Sales Category
- Go to the hosting Service Plan in question (which should be set as a parent subscription for domain subscription)
- Switch to the 'Up-sales' tab
- Make sure that the Sales Category from the step 3 is present in the list of up-sales, otherwise - add it