Symptoms

The following symptoms are observed on a PBA installation:

  • A cancelled subscription is invoiced twice.
  • A reseller's invoice contains duplicated lines for the same subscription(s).
  • The corresponding billing order (with the first subscription charge) has the Cancelled status.

The problem affects PBA 5.4.14 installations.

Cause

This is the result of defects in PBA 5.4.14.

The situation is as follows:

  1. The subscription is invoiced (in a Sales or Billing order).

  2. The Sales/Billing order gets stuck in the Ready to Complete (CR) status. The internal flag NeedConsolidation stays active; it is set to "Yes" even if the subscription is already invoiced and paid.

  3. The subscription is cancelled by the customer.

  4. All the orders with the not-final status are cancelled along with the subscription. So, the Sales/Billing order in the Ready to Complete status is cancelled, and the invoice and other A/R documents are detached from it.

  5. During the next account billing, PBA checks all the orders that require invoicing (by checking the internal flag NeedConsolidation) and invoices with cancelled Sales/Billing orders.

Resolution

See the resolution part in the Parallels Knowledgebase article #117291 Invoiced orders are stuck in the "Ready to Complete" status.

Internal content

Link on internal Article