Symptoms

An attempt to place an order to register a domain in the Parallels Business Automation (PBA) Control Panel results in the following error message:

Domain 'domain_name' is already used. 

Cause

There are two possible causes:

  1. The domain already exists in PBA under a customer account.

  2. The domain is already registered under the Provider's account in the corresponding registrar and cannot be registered again.

During a domain registration order, PBA sends a request to the registrar configured as Domain Availability Checker for the proper TLD (Top-Level Domain) in Domain Manager. The registrar replies that the domain is already registered under the Provider's account. As a result, the order to transfer the domain (which is already registered under Provider's account in the registrar) cannot be placed.

Resolution

Make sure that the domain in question does not exist in PBA Domain Manager:

  1. Login to the PBA Provider Control Panel
  2. Go to External Systems Director > Domain Manager > Domains
  3. Search for the problem domain

If the domain is already present in PBA Domain Manager and has the Registered status, it cannot be registered again.

If the domain is absent in PBA Domain Manager, it may be already registered in the Provider's account in the registrar. In this case, follow the steps below to resolve the problem.

Solution 1

The domain can be migrated to PBA via the API. The following sequence of API methods is used for domain subscription creation:

  1. DomainSubscrAdd_API - creates the domain subscription in PBA
  2. pem.addSubscription - creates the default DNS hosting subscription in POA, with the same ID as the domain subscription in PBA created in step 1
  3. pem.addDomain - assigns DNS hosting for the domain to POA's default DNS subscription.

Refer to the PBA documentation for more details: Domain Subscription Migration

Solution 2

Temporarily change the domain availability checker to another one, place the order, then revert the changes back and complete order processing using the Domain Conflict Resolver.

  1. Log into the PBA Provider Control Panel
  2. Go to External Systems Director > Domain Manager > Domain Zones
  3. Click on the required domain zone and change the availability checker to another registrar than the one currently configured
  4. Place the transfer order for the domain
  5. The order will fail (because the domain is already registered with the registrar)
  6. Complete the failed order using Domain Conflict Resolver
  7. Revert the changes for the zone which you made in the step 3.

Internal content