Symptoms

Provider is using customized Order Flow in BA with transitions depending on the Service Plan a customer subscribed to (usually used for integration with the third-party billing systems). For example, there are two transitions from the Sales Order status TV (Manual Customer Account Verification is not required) - one for free services (the subscriptions based on the Service Plans indicated in the condition):

and the other for the rest paid services:

However this does not work as expected - the Sales Orders for the subscriptions based on the Service Plans with ID 1-5 go to the NR status as if the condition is not checked.

The situation may be a bit different - there is a manual transition to some order status with a condition indicated; clicking the button to push the order to the next status ends up in the error "Order Flow Condition prohibits Order Flow Transition", even though the Plan ID the subscription is based on is present in the condition.

Cause

  1. Conditions in Order Flow transitions are configured incorrectly.

  2. Order details are absent in the Order.

Resolution

  1. Make sure the conditions syntax is correct, in one case the plans matching must be checked:

    "##DetailList#_@@Detail_PlanID@_##/DetailList#"~="(_1_|_2_|_3_|_4_|_5_)"    
    

    in the other - the plans mismatch:

    "##DetailList#_@@Detail_PlanID@_##/DetailList#"!~"(_1_|_2_|_3_|_4_|_5_)"
    
  2. The order details may be missing as their total is 0. In that case it is required to set the 'Show Zero Price' option to 'Yes' in the corresponding Service Plan(s) settings in BA Provider Control Panel:

    • Go to Product Director > Plan Manager > Service Plans
    • Click on the required Service Plan
    • Switch to the 'Subscription Periods' tab
    • Enable the 'Show Zero Price' option for recurring/setup/cancellation fees

Otherwise the order details are not generated for Sales Order and BA cannot check the condition (it is based on the order details).

The orders placed when Order Flow was incorrect and orders without details may be pushed through only by temporarily change in the Order Flow:

  • Remove the condition
  • Process the order
  • Put the correct condition

Internal content