Symptoms

OSA cannot create subscription with Linux or Windows shared hosting service due to the following error message:

Default domain cannot be determined: domain id is not specified as activation parameter ds.domain_id and there is no default brand for account #account_id

The error message may be shown in OSA Provider Control Panel when creating new subscription, in BA Control Panel in a failed order properties and in output of OSA OpenAPI request.

Cause

There are two reasons of the problem:

  • The 'Default Domain's Identifier' parameter is empty either in the corresponding resource type (based on the Physical hosting (Apache) or Physical hosting (IIS) resource class) or in the Service Template which is used to create subscription or in both.

  • The customer account does not have brand assigned.

When OSA creates Windows or Linux shared web hosting subscription it uses the domain defined by the 'Default Domain Identifier' parameter in shared hosting resource type or Service Template or the domain defined in customer's brand to generate so called Instant Access URL for a customer's webspace on shared hosting server. Since neither default domain nor domain in brand are available OSA cannot generate instant access URL and request to create subscription fails.

Resolution

Set the value of the 'Default Domain's Identifier' parameter in the corresponding shared hosting resource type based on the 'Physical hosting (Apache)' or 'Physical hosting (IIS)' resource class or in the Service Template which is used to create subscription or in both.

Use the following instructions in the OSA Provider Guide for more details about tuning parameters in OSA resources and/or Service Templates:

Also, to prevent the similar problem in the future mark one of existing brands as default (if there is no default brand yet) in OSA Provider Control Panel at System > Settings > Brands. After that all newly created customers will be automatically assigned to the default brand.

OSA Control Panel does not allow to set/modify brand for existing customers, contact Odin Technical Support to set brand for existing customer accounts with empty brand if you want.

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