Symptoms

An upgrade, downgrade, or Service Plan switch order, or Service Plan synchronization for an OA subscription, fails in BA with the error message Resource overusage attempt like in the example below:

Upgrade failed:Parallels Operations Automation error #error_code #2005, extype_id #100, module_id #ResourceManagement, Resource 'resource_name' overusage attempt (subscription #<id>, usage 5, limit 1).

The error message is generated by OA.

Cause

An order is trying to set a limit on a resource in the subscription that is below its current actual usage in OA, and OA does not allow you to set a limit on a resource that is below its actual usage because it may lead to service unprovisioning.

This may happen in the following cases:

  • A customer purchased five units of a resource in their subscription, so BA knows about these five purchased units of the resource only. A Provider staff member manually increased the limit on the resource in the OA Control Panel, on the Resources tab in the subscription properties, to, e.g., 10. A customer used all of these additional units of the resource and then tried to place an upgrade order in BA on, e.g., three additional units of the resource. BA is not aware of the manual resource adjustment in OA, so during upgrade order provisioning, BA will try to set a limit on the resource of 8 (five existing units of the resource in the customer subscription, plus three additional items in the upgrade order). Order provisioning will fail on a request to OA to set a limit for the resource as 8 with the error message Resource overusage attempt.

  • A customer subscribed to a BA Service Plan with an allowed limit of a resource set to, e.g., 10 and used all the units of the resource. Then the customer decided to switch to another Service Plan with the maximum allowed units of the resource fewer than 10. Again, in this situation, order provisioning will fail on a request to OA to set the resource limit below its actual usage.

Resolution

There may be several ways to resolve the conflict:

  1. Remove some used units of a resource in the OA Control Panel (if possible) so that usage of the resource in OA is equal to the limit that BA is trying to set for the resource. The name of the resource, its current usage, and the limit that BA is going to set in the subscription in OA are present in the error message in the failed order, e.g., in the example above, the actual usage of the resource in OA is 5, while BA is going to set the limit to 1. Of course, if the customer removes some used units of the resource, part of the used service will be unprovisioned.
  2. Cancel the failed upgrade order and place a new one that will set a limit on the resource in OA to a value equal to or greater than the actual current usage. For example, in the example above, a customer has to place an upgrade order on five units of the resource.

Internal content