Symptoms

A customer added a domain to their account in POA Control Panel and provided Hosted Exchange service on it.

The domain is absent in the list of accepted domains in Active Directory, as a result mail cannot be delivered to mailboxes on the domain.

Cause

There may be two reasons of the problem:

  1. The domain was removed from the list of accepted domains manually

  2. The domain was not added to the list of accepted domains due to problem with data replication between Active Directory Domain Controllers

The latter case may happen if the customer removed Hosted Exchange service from the domain in POA Control Panel and added it back immediately. In this case POA generate pair of provisioning tasks ('Unregister accepted domains' and 'Register accepted domains') and AD Domain Controllers do not have enough time to replicate data between each other between two consecutive tasks. As a result the domain cannot be added to the list of accepted domains because in accordance with data in Active Directory the domain is already present in this list.

Resolution

Add the domain manually to the list of accepted domains using the Exchange Management Console (EMC) or the New-AcceptedDomain cmdlet in the Exchange Management Shell (EMS):

New-AcceptedDomain -DomainName example.com -Name example.com -DomainType Authoritative

Use the proper domain type in the cmdlet, it may be Authoritative or InternalRelay. The actual domain type may be seen in the POA Customer Control Panel on the Exchange tab in the domain properties:

Note: to be able to see and manage Exchange domain type in the Customer Control Panel Provider has to enable the 'Allow management of domain configuration' parameter in the POA Provider Control Panel at Service Director > Hosted Exchange Manager > Exchange Settings.

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