Symptoms

The POA Customer Control Panel shows a domain name that is not clickable, does not have the domain ID and cannot be assigned to any service (like website or mail hosting):

Cause

This is so called 'Domain request', an entity created in POA after domain was submitted for registration in PBA. A domain request is typically converted to fully functional domain with possibility to assign services after domain is successfully registered/transfered (PBA will send corresponding request to POA after registration/transfer process is completed on registrar side).

A customer cannot manage domain request until registration/transfer is completed in PBA.

Resolution

First of all ensure that there is no unprocessed order for registration/transfer of this domain in PBA - check non-completed Sales Orders of the customer account in question, check status of the corresponding domain subscription in PBA.

If there is non-completed order on domain registration/transfer, it should be completed and domain request will be converted to the ordinary domain automatically.

If there are no pending orders for the domain in question, you can use the pem.removeDomainRequest POA OpenAPI method to remove the domain request.

The following XML request will remove a domain request for a domain with name 'domain.tld' from the subscription 1000101:

<?xml version='1.0'?>
<methodCall>
 <methodName>pem.removeDomainRequest</methodName>
 <params>
  <param>
   <value>
    <struct>
     <member>
      <name>subscription_id</name>
      <value><i4>1000101</i4></value>
     </member>
     <member>
      <name>domain_name</name>
      <value><string>domain.tld</string></value>
     </member>
    </struct>
   </value>
  </param>
 </params>
</methodCall>

See additional details about the API method in the POA Public API Reference Guide: pem.removeDomainRequest.

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