Symptoms

A Provider created and released a credit memo for a customer account in PBA, so the customer has an open credit memo on file.

The customer belongs to the Customer Class with the Auto Apply Credits option enabled; this means that existing credit documents of the customer should be automatically applied to their newly created invoices and debit memos.

The customer does not have any payment method set up for auto payments in their account in PBA.

The customer placed an order in PBA to subscribe to services or to upgrade/downgrade/renew their existing subscription. PBA processed the order and issued an invoice, which, in accordance with the Customer Class settings, should have been closed by the existing credit memo.

However, PBA did not apply the existing credit memo to the customer's invoice automatically, so the customer has an open invoice and an open credit memo in PBA. The customer's order is stuck in the Waiting for Payment (WP) status.

Cause

The problem is caused by incorrect processing of the existing customer's credit AR documents during order provisioning in PBA 5.4.11 - 5.4.13.

Resolution

The problem is fixed in PBA 5.4.14, upgrade PBA to this or later version.

For the time being, a Provider (or reseller) may use one of the following solutions:

  • Apply a credit memo to the customer's invoice manually in PBA Control Panel

  • Create and release payment for the customer using the check/cash payment method instead of a credit memo

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