Symptoms
In Parallels Virtual Automation (PVA), PVA Agent cannot start. The service is in the pending state:
C:\>net start pvaagent
The PVA Agent service is starting...............................................
................................................................................
................................................................................
C:\>sc query pvaagent
SERVICE_NAME: pvaagent
TYPE : 10 WIN32_OWN_PROCESS
STATE : 2 START_PENDING
(STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x95
WAIT_HINT : 0xbb8
Cause
On each startup, PVA Agent performs a health check of all containers by entering them via vzctl exec
. If this operation fails, PVA Agent may hang on startup.
In this instance, some containers are not accessible to the "vzctl" utility:
C:\>vzctl enter 1158
ERROR: Response timeout for operation 'exec'
Environment is not changed.
Reasons for a failing "vzctl" may vary. Some possibilities include:
- RDP attacks
- No privileges to execute cmd.exe inside the container
- The container is damaged from the inside ("cmd.exe" may be missing, or its VZFS link is pointing to a nonexistent file). In this case, we recommend contacting Parallels Technical Support for help.
Resolution
Find the containers that have problems:
echo exit > exit.cmd for /f %i in ('vzlist -Ho veid') do vzctl enter %i < exit.cmd
Stop the problematic container(s). Repeat Step 1 (above) until all these containers are stopped.
vzctl stop CTID
Kill the hung PVA Agent service:
taskkill /im pvaagentd.exe
Start the PVA Agent service:
net start pvaagent
Restart the problematic container(s).
vzctl start CTID