Symptoms

Provider cannot attach a server to an IP Pool in a pool properties screen in the POA Provider Control Panel at Infrastructure Director > Network Manager > IP Manager > IP Pools > select pool > Hosts tab, the following error message is displayed:

Attach IP pool to network interface(s) operation result
No network interfaces attached to IP pool. Reason IP pool 'Shared IP Pool' may not suitable for selected network interface 'venet0'(venet0).
Please check IP range and subnet mask.

The same error message appears if Provider is trying to attach an IP pool to a server.

Cause

The Shared IP address assigned to network interface on the problem server is not suitable - it does not belong to the IP Pool being attached. Since 5.4 POA requires that IP addresses assigned to the shared network interface on a server match IP pool by at least two first octets.

The requirement above allows to avoid deployment problems caused by assignment of IP pools to the wrong network interfaces, e.g. POA does not allow to attach Backnet IP pool to a Frontnet network interface (which usually use totally different IP networks).

Resolution

  1. If the server in question does not have any customers' services then the solution is as follows:

    1. Delete the problem server from POA (it must not have customers' services provisioned).

    2. Add additional network interface to the server which satisfy the above-mentioned requirement.

    3. Register the server in POA again.

    4. Attach the desired IP Pool to the new network interface.
  2. If the server has provisioned customers' services and they cannot be migrated to another server(s) then Provider may attach another IP pool which satisfy the requirement above to the server.

Internal content

Link on internal Article