Symptoms

A customer goes to the PBA Online Store to subscribe to PA services. They select Service Plan, subscription period, choose domain and other parameters. On the checkout step the customer enters their account details. After the customer filled all account and payment method details they do not hit the Place Order button immediately (due to whatever reason), the customer returns to the Online Store after some period of inactivity and clicks the Place Order button.

The Online Store does not place order as customer expected, instead the customer is being redirected to the home page of the Store. The customer has to start purchase process over.

The same situation happens if the customer logged in to the store and has been idle for some time.

Cause

The customer's session in the Online Store expired after the proper timeout.

In the Online Store log file store.log the following entry may be found when the customer experiences problem:

 [12-12-20 14:15:28.174 TEMPLATESTORE 0001254 NTE]     #######  start trace  #################
 [12-12-20 14:15:28.189 TEMPLATESTORE 0001254 NTE]     started at 12-12-20 14:15:28.189
 [12-12-20 14:15:28.206 TEMPLATESTORE 0001254 NTE] ==> Session expired  <==
 [12-12-20 14:15:28.206 BMAPI         0001254 NTE]     PHPSESSID: kpl92i2p63555cis5ilgrvrar7
 [12-12-20 14:15:28.207 BMAPI         0001254 NTE]     USERID: NOBODY

Resolution

PBA Online Store is using system PHP session timeout. You may check the variable:

[root@test ~]# grep session.gc_maxlifetime /etc/php.ini
session.gc_maxlifetime = 900
;       setting session.gc_maxlifetime to 1440 (1440 seconds = 24 minutes):

and adjust it according to your needs.

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