Symptoms

Existing external domain could not be added as 'Registered Elsewhere' in POA Customer Control Panel as the 'Add Existing Domain Registered Elsewhere' button is missing in CCP.

A customer can only register the new domain, transfer the existing one or add a subdomain:

Cause

There may be several reasons for such behavior:

  1. A customer is logged into CCP under the staff member (user), which does not have privileges to add new domains.

  2. The system property 'Ability to add domains from customer CP' is disabled in POA.

  3. A customer does not have available units of the DNS Hosting resource in their subscriptions.

Resolution

Cause #1 - lack of privileges

A user should have a role with the 'Own Domains' privilege set to 'Admin' to be able to add new domains in POA CCP. Check the role assigned to the staff member who experiences problems with adding new domains in POA Provider CP:

  1. Go to Configuration Director > Security Manager > Users.
  2. Find the problem user and click on it.
  3. Switch to the Hosting Roles tab.
  4. Click on a role on the screen.
  5. Switch to the Privileges tab.
  6. Find the Own Domains privilege.
  7. Check if the privilege is set to Admin.
  8. Repeat the steps 4-7 for all roles of the user.

If the user has no assigned roles with the Own Domains privilege set to Admin, then consider one of the following actions:

  • The preferred solution is assigning a role with the Own Domains privilege set to Admin to the user (usually the role Account Administrator has the desired configuration).
  • Set the Own Domains privilege to Admin in one of roles assigned to the user - this solution will affect all users with the role assigned.

Note Changes will be applied on the next login of customer in POA CCP.

Cause #2 - disabled system property

Follow these steps to resolve the issue:

  • Log into POA Provider Control Panel.
  • Go to System Director > Configuration Manager > System Properties.
  • Enable the Ability to add domains from customer CP system property.

Cause #3 - insufficient resources

Check in Provider or Customer CP if a customer has available units of the DNS Hosting resource in at least one subscription.

If no, please suggest customer make the following changes:

  • Purchase additional units of the DNS Hosting resource in PBA Customer CP.
  • Upgrade some of their subscription to another PBA Service Plan with more units of the DNS Hosting resource included.
  • Increase the limit of the DNS Hosting resource in POA Service Template of some of customer's subscription and then synchronize resources in Service Template via PBA using the Knowledgebase article #5955.

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