Symptoms
Switching from the OA Control Panel to BA does not work - after clicking the 'Billing' link in the OA Control Panel, the session ends and one of the following sympoms is observed:
- BA login page is displayed instead of actual login
- duplicated OA right frame instead of BA page
- exception "Error occurred on attempt to initialize Billing Manager CP (https://url) session: Session ID was not found in response from Billing Manager. Please check password is correct."
- Unable to create Account.
The following error message is logged in the __amt_service.log
and www.log
/billing.www.log
:
No root access granted for this address
Cause
The IP address of the OA server (control panel/management node/branding) is absent in the ip_access.db file on the BA Application server.
Resolution
Put IP addresses of all OA UI and Branding servers into the ip_access.db file on the BA Application server to make it possible to log in to BA with the common password from these IPs:
Linux:
/usr/local/bm/conf/ip_access.db
- Windows:
C:\Program Files\Parallels\PBA\conf\ip_access.db
(this is the default path, it may be changed on a specific installation)
Restart PBA:
Linux:
/etc/init.d/pba restart
- Windows:
ssm restart pba
Notes:
Add the IP address to the special section [0] in the ip_access.db file.
Use the proper format of records in the file, like this(please make sure that there is no space after true):
[0] 192.168.1.101 = true
Refer to the documentation for more details.