Symptoms

A provider created two similar Service Plans in BA, and wants to allow customers to switch between the plans. However the desired service plan does not appear in the list of plans which may be configured as an upgrade/downgrade.

Cause

Plans have different billing types, including post-paid and pre-paid. The billing type is controlled by the parameter Charge for Subscription in the Service Plan properties. The parameter may be set to one of the following values:

  • Before Subscription Period
  • Before Billing Period
  • After Billing Period

The two first options define a pre-paid plan, while the last one defines a post-paid plan. BA does not allow you to switch from pre-paid plans to post-paid ones and vice versa, which is why plans with different billing types cannot be configured on the Allowed Upgrades/Downgrades tab. For details please refer to BA documentation - Configuring Switch Parameters.

The restriction is implemented to prevent accounting problems and errors in fee calculations.

Resolution

Consider making both plans belong to the same billing type (pre- or post-paid).

Keep in mind that BA does not allow you to change the billing type of a Service Plan if the plan already has subscriptions or is delegated to resellers.

The feature request #PBA-80618 ("Switch plans from prepaid to postpaid and vice versa") exists to implement the described functionality.

Internal content