Symptoms

Plesk Panel reinitialization from the Customer Control Panel (CP) fails with this error:

The following error(s) occurred during the last operation on the VPS with Parallels Plesk Panel: "https://10.39.84.129:8443/enterprise/control/agent.php : protocol misconfiguration". Please fix the problems and try again or contact your provider. Plesk is accessed under user "admin", use Change Admin Password button below to change the password. If you have re-installed VPS with Plesk, use Reinitialize button to reset Plesk configuration to defaults.

In the Task Manager in the Operations Automation (OA) Provider CP, you can find the failed task "Plesk in VPS initial setup" for the container:

Task name    Plesk in VPS 236: initial setup
Last execution output    https://10.39.84.129:8443/enterprise/control/agent.php : protocol misconfiguration

In /var/log/poa.debug.log on the OA Management Node, you see that the error protocol misconfiguration is caused by a Plesk license problem. The actual error message is as follows:

May 18 18:05:06 pa-poa : TRC [1:31846:b63f6b90:9726 1:31930:b7053b90 PleskBridge]: [task:433140 traverseTree] path = /packet/server/lic_install/errtext, value = The amount of currently used resources overrides the limits defined by your license. The number of websites hosted on the server exceeds the limits defined by your license. You have 1 sites hosted; your license allows hosting only 0 sites. The number of served customer accounts exceeds the limits defined by your license. You have 1 customer accounts currently served; your license allows serving only 0 customer accounts.
May 18 18:05:06 pa-poa : ERR [1:31846:b63f6b90:9726 1:31930:b7053b90 lib]: [task:433140 PleskBridge::StandardPacketParser::returnNodeValue] {module_id="PleskBridge"; code="4"} https://10.39.84.129:8443/enterprise/control/agent.php : protocol misconfiguration

Cause

In the Initial setup task, OA performs an installation of the Plesk license, which is stored in the OA database. However, this license can become outdated as the result of a manual Plesk Panel upgrade.

During a Plesk Panel upgrade procedure, the Plesk license is upgraded to the latest version. In fact, it is upgraded in Odin Key Administrator, not in OA. Therefore, OA is not aware that Plesk Panel was upgraded. The outdated license is still stored in the OA database and is not accepted by Plesk Panel during reinitialization.

Resolution

Use the following steps to synchronize the Plesk license in OA and Plesk Panel:

  1. Synchronize the Plesk license with Odin Key Administrator in the Business Automation (BA) Provider CP:

    Top > External Systems Director > License Manager > Licenses > click the Plesk license used for the customer's subscription > click the Sync License button.

  2. Install the license by clicking the Install License button. As a result, a task with the name Plesk in VPS CTID: install license is created in OA. However, this task's execution will be blocked by unprocessed tasks for Plesk in the container reinitialization.

  3. To be able to execute the "Plesk in VPS CTID" task, do the following: install the license, and make sure all tasks related to the container are temporarily canceled.

    Cancel all tasks related to the container, except for the task "Plesk in VPS CTID": install the license. This can be done with the help of the article How to find task(s) related to a customer's PVC container.

    Top > System Director > Task Manager > select tasks to cancel, and click the Cancel Tasks button.

  4. Execute the task Plesk in VPS CTID: install license. After this task is processed, the PP license will be updated in OA and installed on the Plesk Panel server.

  5. Run all canceled tasks related to the container:

    Top > System Director > Task Manager > Canceled Tasks > find the previously canceled tasks by queue name and run them.

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