Symptoms

You have Exchange Server 2010 (Enterprise Mode) and BlackBerry Enterprise Server (BES) 5.0.x. You have a mailbox with BlackBerry support enabled, but the BlackBerry device cannot be activated. In the BlackBerry Enterprise Server's MAGT log file, the MAPIMailbox - OpenMsgStore failed error message appears.

Note: The location of the BlackBerry Enterprise Server log files can be obtained by going to the BlackBerry Enterprise Server, selecting the option to Start > BlackBerry Enterprise Server > BlackBerry Server Configuration > and clicking the Logging tab.

Cause

The possible causes of the problem are as follows:

  • The BES service account's permissions have been missed.
  • The BES MAPI profile is corrupted.
  • There are insufficient mailbox and delivery limits for the target mailbox.

Resolution

To resolve the problem, perform the following steps:

  1. On the Exchange Mailbox Server, open the Exchange Management Shell.

  2. Execute the

    PS> Get-OrganizationConfig | Add-ADPermission -DomainController FQDN\_OF\_DOMAIN\_CONTROLLER -user BESAdmin -ExtendedRights ms-Exch-Store-Admin, "Receive as," "Send as" command.
    
  3. Execute the

    PS> Get-MailboxDatabase | Add-ADPermission -User "BESAdmin" -AccessRights ExtendedRight -ExtendedRights Send-As,Receive-As,ms-Exch-Store-Admin command.
    
  4. Make sure the BES service account's permissions are configured. See the POA Hosted Exchange Deployment Guide >> Deploying BlackBerry Enterprise Server 5.0.3 for Microsoft Exchange 2007/2010/2010 Multi-Tenant and Assigning service account permissions for a BlackBerry Enterprise Server for Microsoft Exchange KB article for details.

  5. Recreate the BES MAPI profile. See the How to recreate the BlackBerry Enterprise Server MAPI profile KB article for details.

  6. If the problem still exists, open Parallels Operations Automation (POA) CCP and increase the mailbox and delivery limits of the target mailbox.

    For example, if the size of the target mailbox is 50MB or larger:

    • set Prohibit send at to 50MB or larger
    • set Size limit to 50MB or larger
    • set Maximum incoming item size to 50MB or larger
    • set Maximum outgoing item size to 50MB or larger

Internal content