Symptoms

Office 365 provisioning tasks fail with the error message

An unsecured or incorrectly secured fault was received from the other party.

Cause

  1. The time setting is incorrect on the MOSI gateway server. MOSI requests contain a digitally signed time stamp, and Microsoft will only tolerate a maximum time difference of five minutes. This issue is described in the MOSI SDK guide in the section WS-Security Header.

  2. SSL certificate installed on MOSI Gateway server expired. Use IIS Manager to check SSL certificate installed on the MOSI Gateway web site.

Resolution

  1. Correct the time and configure a reliable time source on the MOSI Gateway server. If the MOSI gateway is joined into Active Directory domain and the time is synced from there, configure a time source on a domain controller that holds the PDC Emulator role.

  2. Install correct SSL certificate on MOSI Gateway server following procedure described in the Odin Automation Office 365 Integration Provider's Guide.

Once the problem with incorrect time or SSL certificate is solved on the MOSI gateway, resubmit all failed OA background tasks related to Office 365 services provisioning.

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