Symptoms
Provider created Service Plan in PBA-E, enabled the option 'Published' in plan properties, however Service Plan is not available in the Online Store.
Cause
Most probably Service Plan is not included into a Sales Category or corresponding Sales Category is not configured in the needed Online Store screen.
Resolution
In order to publish Service Plan in the Online Store the following conditions must be satisfied:
- The parameter 'Published' is set to 'Yes' in a Service Plan properties
- Service Plan must be included into a Sales Category (not Plan Category)
Sales Category a Plan is included into must be included into the parameter 'CATEGORY_LIST_ID' in the needed screen in Online Store configuration
To solve the problem Provider has to add Service Plan into a Sales Category:
- Log into PBA-E control panel
- Go to Top > Product Director > Plan Manager > Sales Categories
- Click on the needed sales category
- Switch to the tab 'Service Plans'
- Click the button 'Add New Plan'
- On the appeared screen check box left to the needed Service Plan
Click the button 'Add Plan(s) To Category'
Perform the actions below to add Sales Category to the needed screen in the Online Store:
- Go to Top > Product Director > Online Store Manager > Stores
- Make sure that needed Online Store is selected for editing
- Go to Top > Product Director > Online Store Manager > Screens
- Click on the needed screen
- Switch to the tab 'Parameters'
- Click on the parameter 'CATEGORY_LIST_ID'
- Click the button 'Add Categories'
- Select Sales Category you included Service Plan into
- Click the button 'Add'
- Go to Top > Product Director > Online Store Manager > Synchronization Settings
- Click the button 'Synchronize'