Symptoms

Provider created Service Plan in PBA-E, enabled the option 'Published' in plan properties, however Service Plan is not available in the Online Store.

Cause

Most probably Service Plan is not included into a Sales Category or corresponding Sales Category is not configured in the needed Online Store screen.

Resolution

In order to publish Service Plan in the Online Store the following conditions must be satisfied:

  1. The parameter 'Published' is set to 'Yes' in a Service Plan properties
  2. Service Plan must be included into a Sales Category (not Plan Category)
  3. Sales Category a Plan is included into must be included into the parameter 'CATEGORY_LIST_ID' in the needed screen in Online Store configuration

    To solve the problem Provider has to add Service Plan into a Sales Category:

  4. Log into PBA-E control panel
  5. Go to Top > Product Director > Plan Manager > Sales Categories
  6. Click on the needed sales category
  7. Switch to the tab 'Service Plans'
  8. Click the button 'Add New Plan'
  9. On the appeared screen check box left to the needed Service Plan
  10. Click the button 'Add Plan(s) To Category'

    Perform the actions below to add Sales Category to the needed screen in the Online Store:

  11. Go to Top > Product Director > Online Store Manager > Stores
  12. Make sure that needed Online Store is selected for editing
  13. Go to Top > Product Director > Online Store Manager > Screens
  14. Click on the needed screen
  15. Switch to the tab 'Parameters'
  16. Click on the parameter 'CATEGORY_LIST_ID'
  17. Click the button 'Add Categories'
  18. Select Sales Category you included Service Plan into
  19. Click the button 'Add'
  20. Go to Top > Product Director > Online Store Manager > Synchronization Settings
  21. Click the button 'Synchronize'

Internal content