Symptoms

Customers create FTP users from the POA CP; however, they do not work.

Customers cannot access their Linux webspaces via FTP.

Configuration files on a POA-shared FTP server are not updating properly; in particular, authentication files are empty in the /usr/local/pem/ftp/ftp_auth/<SERVICE_ID>/ folder.

Cause

The problem may arise if disk space is exhausted on a server where ProFTPD service is working, and as a result, service configuration breaks.

Resolution

In this particular case, when you see that ProFTPD service configuration is broken, you may try to restore (re-dump) it using the POA OpenAPI method pem.ProFTPD.dumpAllVhostsUsers.

Prepare the file pem.ProFTPD.dumpAllVhostsUsers.xml with the XML API request as provided below on the POA Management Node (MN):

<methodCall>
  <methodName>pem.ProFTPD.dumpAllVhostsUsers</methodName>
  <params>
    <param>
      <value>
        <struct>
          <member>
            <name>service_id</name>
            <value><int>232</int></value>
          </member>
        </struct>
      </value>
    </param>
  </params>
</methodCall>

Replace 232 in the example above with the actual ID of ProFTPD service on the POA installation; this may be found in the POA Provider CP at System Director > Configuration Manager > Services.

After that, execute the prepared API request using a command like the following on the POA MN (you will see an output like that provided below):

~# curl -d@pem.ProFTPD.dumpAllVhostsUsers.xml http://127.0.0.1:8440
<?xml version="1.0" encoding="utf-8"?>
<methodResponse><params><param><value><struct><member><name>status</name><value><i4>0</i4></value></member></struct></value></param></params></methodResponse>

As a result, POA will re-create the configuration of ProFTPD service with the provided ID.

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