Symptoms

After an upgrade to Office 365 19.3, new subscriptions of resellers' customers are created without MPN ID specified on Microsoft side.

It can be seen in sitelog that "partnerId" has value "0":

2020-01-07 10:01:40,852 <5176> [  51] INFO aps_endpoint: GetProvisioningUnits(customer_id: '38fffee5-7897-40b4-abb1-212c524bf50c', offered: [offerId: 031c9e47-4802-4248-838e-778fb1d2cc05, trialOfferId: c0bd2e08-11ac-4836-bdc7-3712e744922f, limit: 2, apsTenantId: 2569cfbd-7eb8-4f03-a24f-5efa6e565181, isAddon: False, isTrial: False, partnerId: 0, apsLicenseId: 758a38e9-f401-4c33-9fa6-aef06fa4233f, user_specific: True, possible_parents: , GetActiveOfferId: 031c9e47-4802-4248-838e-778fb1d2cc05, BillingPeriodCycle: Monthly, FriendlyName: '#1028351: Office 365 Business Premium', OfferName: 'Office 365 Business Premium', PossibleParentsNames: ''.], apsTenantId: '2569cfbd-7eb8-4f03-a24f-5efa6e565181'.
2020-01-07 10:01:40,852 <5176> [  51] INFO aps_endpoint: Need to create subscription for offer '031c9e47-4802-4248-838e-778fb1d2cc05' = 2.

Cause

Reseller mode property for corresponding Office 365 instance is set to Direct CSP Provider.

Starting from 19.3, there is a big difference between Direct CSP Provider and Indirect CSP Provider settings.

See aditional details in documentation:

Office 365 Integration Provider's Guide > The Cloud Solution Provider Scenario > Configuring Resellers

Resolution

In case you have have indirect resellers with MPN_ID attribute specified on billing side, Reseller mode setting should be set as Indirect CSP Provider.

In order to change it, follow steps below:

Operations > Applications > Office 365 > Select required instance > Edit

In order to fix currently affected subscriptions, it is required to change MPN ID manually in Microsoft Partner Center.

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