Symptoms
A Cancellation Order for Kaspersky APS application fails with the following output:
Removal of Service of Subscription #1070031 is failed. Stopping service of Order Item #2438226 failed: Stopping service for Subscription #1070031 failed: Platform error #error_code #-1, extype_id #-1, module_id #, APS suspendable resource '606f6a20-2a0a-4c0b-bec4-a538095535f2' was NOT disabled. Error message: Unknown error
Same error can be found in /var/log/pa/core.log
:
Nov 4 19:55:36.355 : DBG [openapi:789418 remoting-task-98:656 pau]: c.p.p.tracer exit by exception: com.parallels.pa.service.provisioning.ejb.SubscriptionLifecycleIntegratorBean.notifySuspendableResources correlationId openapi:789418 javax.ejb.EJBException: APS suspendable resource '606f6a20-2a0a-4c0b-bec4-a538095535f2' was NOT disabled. Error message: Unknown error
In /var/log/httpd/error_log
on the APS application endpoint, a more detailed output can be observed:
[2019-11-04 19:05:48.706490 UTC] DEBUG Result:
{
"code": 6003,
"error": "Kaspersky::KORMException",
"message": "6003: {\"message\":\"Error(c15367a3-b1f5-4538-a179-95b90574eba3): \\\"Subscription must not be in hard canceled state.\\\" (code 3002)\",\"variables\":[]}",
"stacktrace": [
"#0 /var/www/html/kssfb/lib/KORMClient.php(379): Kaspersky\\KORMClient::HttpRequest()",
"#1 /var/www/html/kssfb/lib/KORMClient.php(392): Kaspersky\\KORMClient->HttpRequest()",
"#2 /var/www/html/kssfb/lib/KORMClient.php(684): Kaspersky\\KORMClient->HttpPost()",
"#3 /var/www/html/kssfb/SubscriptionService.php(599): Kaspersky\\KORMClient->HardCancel()",
"#4 /var/www/html/kssfb/lib/runtime/aps/2/rest.php(1093): SubscriptionService->disable()",
"#5 /var/www/html/kssfb/lib/runtime/aps/2/runtime.php(401): Rest\\RestService->handle()",
"#6 /var/www/html/kssfb/lib/runtime/aps/2/runtime.php(459): APS\\Loader->handleHttpRequest()",
"#7 /var/www/html/kssfb/lib/runtime/aps/2/runtime.php(471): APS\\Loader->process()",
"#8 [internal function]: APS\\Loader->__destruct()",
"#9 {main}"
]
}
Cause
This behaviour has been addressed in an internal request #KESBC-109 and fixed in 1.0-554 package version.
Resolution
Consider an upgrade of Kaspersky APS Application to the aforementioned or newer version to mitigate the cancellation issue.